DIY-HIFI-Forum

Zurück   DIY-HIFI-Forum > Elektronik > Eigenentwicklungen
Registrieren Hilfe Benutzerliste Kalender Alle Foren als gelesen markieren

» Veranstaltungen
 
 
Themen-Optionen
Alt 11.02.2018, 14:10   #201
Keizo
Erfahrener Benutzer
 
Registriert seit: 09.01.2013
Ort: Freiburg i. Br.
Beiträge: 157
Standard

Das Projekt ist absolut herausragend, vielen Dank an Raffael für sein unglaubliches Engagement und die tolle Dokumentation.

Ich befürchte allerdings auch, von der MCU (dezent ) überfordert zu werden. Zumal ich neben der MCU noch einen Bluetooth-Empfänger, Phono-Pre und Vorverstärker bräuchte.

@rkv
Ich habe bisher noch nix zur Stromversorgung gelesen (was mit Sicherheit an mir liegt ). Was brauche ich denn für MCU-DSP-AMP1-4?
Lieben Dank und mach weiter so
Keizo ist offline   Mit Zitat antworten
Alt 11.02.2018, 14:21   #202
rkv
Erfahrener Benutzer
 
Registriert seit: 20.11.2015
Ort: Verden
Beiträge: 348
Standard

Wofür bräuchtest Du den Bluetooth-Empfänger? Für Audiostreaming? Denn zur Steuerung ist ja schon ein Bluetoothmodul vorgesehen.

An Spannungen werden benötigt:
+12V für DSP, MCU, ADC, DAC etc.
+48V für Verstärker. Diese Spannung ist jedoch abhängig vom verwendeten Chip. Daher ist hierzu das entsprechende Datenblatt zu befragen. Theoretisch ist es sogar möglich, Verstärker 1+2 mit einem anderen Chip als Verstärker 3+4 jeweils mit unterschiedlichen Spannungen zu bestücken.

Bei hinreichend Interesse kann ich mir auch vorstellen, soetwas wie eine Teilbestückung in Auftrag zu geben. Bei 10 Platinnen brauche ich beim Bestücker nicht anfragen, das wird zu teuer, aber darüber hinaus lohnt sich das irgendwann, wenn man die Rüstkosten auf die Gruppe umlegt.

Raphael
rkv ist offline   Mit Zitat antworten
Alt 11.02.2018, 18:05   #203
Keizo
Erfahrener Benutzer
 
Registriert seit: 09.01.2013
Ort: Freiburg i. Br.
Beiträge: 157
Standard

Hi Raphael,

danke für deine Antwort. Ich möchte den Thread nicht unnötig kapern, sollte sogar mal einen eigenen Thread erstellen.
Nur so viel: Ja, Bluetooth Streaming wäre mir wichtig.
Keizo ist offline   Mit Zitat antworten
Alt 13.02.2018, 13:23   #204
jnofear
Neuer Benutzer
 
Registriert seit: 05.12.2016
Ort: Franken
Beiträge: 6
Standard

Wie lässt sich denn die Nachfrage einschätzen?
Vielleicht einfach eine Excel-Liste auf Google Docs wo jeder Interessent erst mal unverbindlich seinen Namen einträgt, anzahl der Platinen etc. man könnte dor auch ein Word Dokument mit der Beschreibung der Baugruppen hinterlegen, dann muss man nicht immer den ganzen Thread durchblättern
jnofear ist offline   Mit Zitat antworten
Alt 17.02.2018, 23:22   #205
rkv
Erfahrener Benutzer
 
Registriert seit: 20.11.2015
Ort: Verden
Beiträge: 348
Standard

Guten Abend,

ich habe leider sehr schlechte Nachrichten: Die USB-Verbindung der ATMEL-MCU funktioniert nicht. Ich bin noch nichtmal dazu gekommen, meine eigen Software aufzuspielen, es scheitert schon vorher. Angeblich kommt die AT32UC3A3256 mit einem vorinstalliertem DFU Bootloader, um Firmware per USB einspielen zu können. Aber dieser Bootloader wird nicht erkannt, egal ob Linux, Mac oder Windows, das USB-Gerät wird nicht erkannt und somit kann keine Firmware aufgespielt werden. Ich habe die letzten Tage viel Zeit damit verbracht, eine Lösung zu finden. Fehlanzeige.
Ich habe alle doppelt und dreifach überprüft. Konnte keinen Fehler in der Schaltung finden. Interessanterweise reagiert die MCU auch, wenn man sie an ein JTAGICE3 dranhängt. Das bringt aber nicht viel, da JTAGICE3 nur von Studio 7 unterstützt wird, Studio 7 aber wiederum nicht mit dem UAC2-Projekt zurecht kommt...
Die Supportseiten sind seit der Übernahme durch Microchip ein einziges Chaos. Die meisten Links zu Atmel funktionieren nicht mehr und die Umstellung der Entwicklungs-IDE von Eclipse auf Visual Studio hat der ganzen Sache scheinbar den Rest gegeben. Ich dachte bisher, ich wäre Kummer von ADI gewohnt, aber diese ATMEL/Microchip-Geschichte übertrifft das nochmal. Lange Rede, kurzer Sinn, ich stehe jetzt also mit einer MCU da, auf die ich keine Firmware aufspielen kann. Und auf genau so ein Theater habe ich sowas von keine Lust.
Wäre ich mal besser bei XMOS geblieben, da habe ich schon ein funktionierendes Projekt zusammen mit den ADAU1452, aber ich wollte ja unbedingt 10Eur sparen...

Ich habe derzeit noch keine Idee, was ich jetzt mache. Falls sich also einer mit den AVR32 auskennt, her mit den Ideen.

Raphael
rkv ist offline   Mit Zitat antworten
Alt 18.02.2018, 12:34   #206
KlaRa
Neuer Benutzer
 
Registriert seit: 20.01.2018
Beiträge: 21
Standard

Zitat:
Ich habe derzeit noch keine Idee, was ich jetzt mache. Falls sich also einer mit den AVR32 auskennt, her mit den Ideen.
Hilfe könnte man u.U. hier bekommen.
https://www.mikrocontroller.net/foru...ler-elektronik

Wäre sicher ein Versuch wert.
mfg Klaus
KlaRa ist offline   Mit Zitat antworten
Alt 18.02.2018, 12:45   #207
Spatz
Nachwuchs
 
Registriert seit: 16.12.2008
Ort: Hamburg/Erlangen
Beiträge: 494
Standard

Kann es sein, dass die MCU selbst einfach defekt ist?
Spatz ist offline   Mit Zitat antworten
Alt 18.02.2018, 13:20   #208
rkv
Erfahrener Benutzer
 
Registriert seit: 20.11.2015
Ort: Verden
Beiträge: 348
Standard

@KlaRa: Hast Du in diesem Forum schonmal gepostet? Die gehen dort mit fragenden Neulingen ungefähr so nett um wie Gabriel und Schulz derzeit miteinander.

@Spatz: Das dachte ich auch schon, aber ich kann ja per JTAG mit der MCU kommunizieren. Witzigerweise läuft aber auch der MCLK nicht an. Sprich, es wird nicht auf die 12MHz umgeschaltet, sondern es bleibt beim internen RC-generierten Takt.
rkv ist offline   Mit Zitat antworten
Alt 18.02.2018, 13:25   #209
rkv
Erfahrener Benutzer
 
Registriert seit: 20.11.2015
Ort: Verden
Beiträge: 348
Standard

Kommando zurück!

MCU läuft und wird jetzt auch vom USB-Host erkannt und eingebunden. Problemverursacher war der USB-Hub. Habe eben "versehentlich" das USB-Kabel in einen anderen Port gesteckt und siehe da, die MCU wird als USB-Gerät angezeigt in USB Prober.


Dann kann es ja weitergehen, nur muss ich in 30min los, viel werde ich heute nicht mehr machen.

Raphael
rkv ist offline   Mit Zitat antworten
Alt 18.02.2018, 13:47   #210
Spatz
Nachwuchs
 
Registriert seit: 16.12.2008
Ort: Hamburg/Erlangen
Beiträge: 494
Standard

Whoop! Whoop!
Spatz ist offline   Mit Zitat antworten
Alt 18.02.2018, 14:17   #211
Lionheart
Erfahrener Benutzer
 
Registriert seit: 09.08.2016
Ort: Southside (Nähe Stuttgart)
Beiträge: 311
Standard

Zitat:
Zitat von rkv Beitrag anzeigen
Kommando zurück!

MCU läuft und wird jetzt auch vom USB-Host erkannt und eingebunden. Problemverursacher war der USB-Hub. Habe eben "versehentlich" das USB-Kabel in einen anderen Port gesteckt und siehe da, die MCU wird als USB-Gerät angezeigt in USB Prober.


Dann kann es ja weitergehen, nur muss ich in 30min los, viel werde ich heute nicht mehr machen.

Raphael
Oh Mann...
Zum Glück hat sich die Hiobs-Botschaft gleich aufgelöst

Gruß Yves
Lionheart ist offline   Mit Zitat antworten
Alt 18.02.2018, 14:31   #212
Spatz
Nachwuchs
 
Registriert seit: 16.12.2008
Ort: Hamburg/Erlangen
Beiträge: 494
Standard

Ich glaube ja, dass alles schon die ganze Zeit lief, und das nur ein Cliffhanger war, damit es spannend bleibt...
Spatz ist offline   Mit Zitat antworten
Alt 18.02.2018, 15:10   #213
Lionheart
Erfahrener Benutzer
 
Registriert seit: 09.08.2016
Ort: Southside (Nähe Stuttgart)
Beiträge: 311
Standard

Zitat:
Zitat von Spatz Beitrag anzeigen
Ich glaube ja, dass alles schon die ganze Zeit lief, und das nur ein Cliffhanger war, damit es spannend bleibt...
Lionheart ist offline   Mit Zitat antworten
Alt 18.02.2018, 18:21   #214
KlaRa
Neuer Benutzer
 
Registriert seit: 20.01.2018
Beiträge: 21
Standard

Zitat:
Zitat von rkv Beitrag anzeigen
@KlaRa: Hast Du in diesem Forum schonmal gepostet? Die gehen dort mit fragenden Neulingen ungefähr so nett um wie Gabriel und Schulz derzeit miteinander.
Ja, dieses Forum kenne ich schon seit Jahren. Man sollte sein Anliegen nur deutlich und klar schildern. Dort tummeln sich einige gute Experten aus verschiedenen Bereichen. Ich würde Dein Problem in der Tat mal dort vorstellen. Mit Deinem Sachverstand triffst Du sicher auch den richtigen Ton. Also, keine Bange.

Zitat:
Kommando zurück!
OK, zu spät gesehen.

mfg klaus
KlaRa ist offline   Mit Zitat antworten
Alt 19.02.2018, 08:50   #215
buyman
Benutzer
 
Registriert seit: 18.09.2015
Ort: Salzburg
Beiträge: 84
Standard

Zitat:
Zitat von rkv Beitrag anzeigen
@KlaRa: Hast Du in diesem Forum schonmal gepostet? Die gehen dort mit fragenden Neulingen ungefähr so nett um wie Gabriel und Schulz derzeit miteinander.
Ja, des öfteren. Ist kein Problem, wenn man sein Anliegen genau genug beschreibt und nicht die 1000.e Hausaufgabenlösung haben will.
Ich würde mir bei deiner Fragestellung also keine Sorgen machen.

Das einfach als Hinweis für die Zukunft. Schön, dass sich das Problem von selbst erledigt hat. Und danke für den Hinweis mit dem Chaos von Atmel/Microchip. Mir war Microchip nie sonderlich sympathisch (vor allem was Debugging auf kleinen µCs anging) - damit ist jetzt Atmel auch weg von der Liste für private Projekte.
buyman ist offline   Mit Zitat antworten
Antwort

Themen-Optionen

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu

Powered by vBadvanced CMPS v3.2.2
Alle Zeitangaben in WEZ +1. Es ist jetzt 14:39 Uhr.


Powered by vBulletin® Version 3.8.9 (Deutsch)
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.