» über uns

Zeige Ergebnis 1 bis 6 von 6
  1. #1
    Erfahrener Benutzer
    Registriert seit
    15.02.2015
    Ort
    OWL
    Beiträge
    190

    Standard Modifikationen am TPA3116D2

    Hallo,

    da Olaf dort https://www.diy-hifi-forum.eu/forum/...TL-Auto-On-Off nach den Modifikationen an den TPA3116D2-Boards gefragt hat hier etwas ausführlicher ein paar Details.

    Begonnen habe ich mit den TPAs im Zusammenhang mit einem kleinen FAST System am PC.
    Trennung, Equalizing etc. per APO, raus über die Soundkarte benötigte ich noch Endstufen für die vier Kanäle.

    Die TPAs schienen mir recht attraktiv. Klanglich von vielen gehypt, ausreichend Leistung, einfache Spannungsversorgung und preislich attraktiv. PBTL war nicht wirklich erforderlich, fand ich jedoch sehr sympathisch.
    Ich habe mich dann ein wenig umgeschaut und im Wesentlichen wegen des Layouts zwei XH-M190 V3 bestellt.

    Der Plan war jeweils das Poti zu entfernen und gegebenenfalls die Verstärkung anzupassen.
    Das war nicht ganz ausreichend bzw. hat nicht auf Anhieb funktioniert. Problem war die fehlende Synchronisierung zwischen den beiden Chips je Board.
    Das führte zu einem leichten Zirpen / Zischeln auf den Ausgängen.

    Offensichtlich hat der Hersteller die Synchronisierung selbst nicht in den Griff bekommen und deshalb beide Chips als Master konfiguriert.
    Ursächlich ist da vermutlich ein Fehler im Datenblatt; mit den von TI angegebenen Bauteilen kann eine Master/Slave Konfig nicht korrekt synchronisieren. Die richtigen Werte finden sich Datenblatt vom TPA3116D2EVM.
    Mit den korrekten Werten bestückt waren die Ausgänge ohne Störgeräusche.

    Danach haben die Teile ein paar Wochen klaglos ihren Job gemacht bis bei einem der Module einer der Powerelkos geplatzt ist. Von wegen Nichicon, der Schrumpfschlauch mit der Beschriftung vielleicht .

    In der Zwischenzeit hatte ich ein paar weitere Module geordert die nach und nach angekommen sind, jedoch alle etwas abweichend bestückt waren.

    Das habe ich zum Anlass genommen die Teile komplett zu überarbeiten (zuerst das eine defekte um direkt vergleichen und entscheiden zu können ob Material und Arbeitszeit lohnt; das tat es, so folgten auch die anderen).
    Ich hatte vorher schon einiges über Modifikationen im DIY-Audio gelesen und mir dann überlegt was ich mache.

    Plan war:

    Power-Elkos tauschen

    Die Panasonics passten von Bauform, ESR, Rippelstrom und Preis am besten.


    Koppelkondensatoren von kerko gegen Folie tauschen.

    Viel hilft viel gilt an dieser Stelle nicht unbedingt. Die 1uF sind bei dem Verstärkungsfaktor (26dB), der resultierenden Eingangsimpedanz (30k) vollkommen ausreichend. Bei 20Hz liegt der Frequenzgang damit bei ca. -0,3dB.
    Mehr Kapazität wäre grundsätzlich erstmal kein Problem, führt jedoch zu einer größeren Bauform die sich auf dem Board nicht mehr sinnvoll integrieren lässt. Ab einer bestimmten mechanischen Größe bekommt das Teil zudem auch noch mehr und mehr die Eigenschaft einer Antenne.
    Außerdem verschlechtert sich damit das Startverhalten des TPA da ein größerer Kondensator länger braucht um über die Bias-Spannung voll geladen zu werden -> mehr Einschaltplopp.


    Ausgangsfilter

    Das originale Filter war mit einer 33uH Induktivität realisiert. Von der Bauform kleiner als das was die Lötpads zulassen. Die kleine Bauform resultierte in einem relativ hohen DC-Widerstand; weitere technische Daten unbekannt.
    Da nicht ganz klar welche Impedanz die TPAs auf Dauer zu bedienen haben konnte ich für das neue Filter keine Punktlandung machen. Aber mit APO oder dem DSP ist es kein großes Problem da einzugreifen.
    Prinzipiell könnte man bei dem TPA auf das klassische LC-Filter ja komplett verzichten und eine einfachere Variante mit Ferritperle realisieren. Das war mir EMV-Technisch jedoch zu heikel, daher bin ich auch hier dem Eval-Board gefolgt (10uH/680nF).
    Die Wahl der Induktivität war dann wieder eine Abwägung zwischen dem was auf die Pads passt, geringem DC-Widerstand, hohem Sättigungsstrom und Preis.


    Bootstrap Snubber

    Das Board besitzt im Original kein Bootstrap Snubber. Im DIY-Audio schien Einigkeit zu herrschen: Der TPA profitiert immer davon; quasi eine „must have“ Modifikation, daher auch hier adaptiert.
    Mit etwas filigranem Lötgeschick und der Kombination von THT und SMD-Teilen lässt sich das recht gut auf dem Board integrieren.


    Einschaltploppen

    Um das zu verhindern müssen die TPAs beim Herstellen der Spannungsversorgung einen Moment länger im Mute bleiben. Um das „unmuten“ kurze Zeit zu Verzögern gibt es im TI-Forum einen Post mit einem kleinen Schaltungstrick. https://e2e.ti.com/support/audio/f/6/p/209307/1195915
    Die Bauteile sind im Original Layout ebenfalls nicht vorgesehen und hier wieder in einem Mix aus SMD und THT „Huckepack“ gesetzt.



    Bei den ganzen Änderungen war ab einem bestimmten Punkt klar: Am einfachsten lässt sich alles umsetzen wenn man alles bis auf die TPAs vom PCB entfernt und komplett neu bestückt.
    Netter Nebeneffekt: Alles neue Bauteile aus seriösen Quellen mit bekannten Eigenschaften; keine späten Überraschungen.
    So geschehen; Teile geordert und los.

    Das Ergebnis sieht so aus:
    [IMG]https://www.diy-hifi-forum.eu/forum/attachment.php?attachmentid=41603&d=1516556591[/IMG]
    [IMG]https://www.diy-hifi-forum.eu/forum/attachment.php?attachmentid=41604&d=1516556591[/IMG]
    [IMG]https://www.diy-hifi-forum.eu/forum/attachment.php?attachmentid=41605&d=1516556591[/IMG]

    Der Preis für die Bauteile ist überschaubar; die Zeit und den Aufwand darf man einfach nicht betrachten.

    Neben der Neubestückung habe ich auf der Unterseite noch eine zu klein dimensionierte Leiterbahn und ihre Durchkontaktierungen „verstärkt“. Dazu den Lötstopplack entfernt, die Durchkontaktierung durchbohrt, einen Draht passend zurechtgebogen, aufgelegt/durchgesteckt und von beiden Seiten vollflächig verlötet.

    Hier gut zu sehen: [IMG]https://www.diy-hifi-forum.eu/forum/attachment.php?attachmentid=41606&d=1516556591[/IMG]

    Die auf diesem Bild zu sehenden Folienkondensatoren liegen parallel zu den Power-Elkos. Ob jetzt wirklich notwendig und sinnvoll sei dahingestellt, aber sie beruhigen mein Gewissen.

    Eine mechanische Kleinigkeit gibt es ebenfalls noch zu ändern. Der Kühlkörper wird von der Rückseite der Platine verschraubt auf die TPAs gepresst. Das führt zum Verbiegen der Platine und sorgt so für mechanische Spannungen in den Bauteilen. Gerade Keramikkondensatoren reagieren darauf sehr empfindlich und verursachen schnell Kurzschlüsse wenn sie Risse bekommen.
    Daher einfach eine kleine Unterlegscheibe zwischen Kühlkörper und Platine fügen. Die Dicke auf einem Stück Schleifpapier auf ca. 2-3/10mm weniger als die TPAs auftragen herunterschleifen; dann verbiegt nichts mehr.

    Soweit fürs Erste; mehr fällt mir gerade nicht ein…

    Gruß

    Nico

  2. #2
    gibt's das auch von Sica Benutzerbild von Olaf_HH
    Registriert seit
    19.11.2012
    Ort
    Hamburg
    Beiträge
    4.613

    Standard

    Super, vielen Dank für deinen Bericht.
    In Hamburg sagt man, Moin

    Olaf_HH

    Meine Lautsprecher Projekte auf IGDH:
    DaySi 3/5 ; Schief und Krumm ; Noun MK3 ; Noun Mk2 ; Dyna-Lith OB


  3. #3
    Erfahrener Benutzer
    Registriert seit
    11.03.2014
    Ort
    MZG
    Beiträge
    375

    Standard

    DANKE
    EX4 V1, Monitor CB , Menhir L

  4. #4
    HSG Südbaden Benutzerbild von jones34
    Registriert seit
    22.11.2011
    Ort
    Karlsruhe
    Beiträge
    627

    Standard

    Cool mal wieder etwas Elektronikgebastel zu sehen
    Also bei so viel Modifikation hätte ich ja einfach die Boards neu gemacht
    Warum muss alles so schwierig sein?
    Weil es sonst zu einfach wäre.

  5. #5
    Erfahrener Benutzer
    Registriert seit
    21.07.2015
    Ort
    Beckum
    Beiträge
    517

    Standard

    Hallo Nico,

    ich bin begeistert, starke Leistung. Das geht mein Herz auf.
    wenn ich nicht schon mindestens 20 Verstärker und Endstufen in meinem Regal liegen hätte, würde ich Dir das Gerät sofort abkaufen.

    viele Grüße

    Thomas

  6. #6
    Erfahrener Benutzer
    Registriert seit
    15.02.2015
    Ort
    OWL
    Beiträge
    190

    Standard

    Danke Euch,

    wäre bei den ersten beiden Boards der Elko schon etwas eher geplatzt hätte ich die anderen Boards vermutlich gar nicht mehr bestellt.

    So waren sie halt da. Die Teile einfach alle in den Schrott zu werfen war mir zuwider. Ich meine gar nicht mal das Geld, sondern die Teile, Arbeit und Ressourcen die dafür schon aufgewandt wurden bis die bei mir zuhause angekommen sind.

    Ob das was ich damit gemacht habe die Gesamtbilanz wirklich besser macht weiß ich auch nicht.
    Ich denke, wenn sie so ein paar Jahre stabil ihren Job machen dürfte es sich gelohnt haben.

    Die PCBs neu zu machen habe ich gar nicht ernsthaft in Erwägung gezogen. Das Layouten liegt mir nicht, da fehlen einfach Erfahrung und Praxis.
    Da geht mir das Löten einfacher von der Hand; dauert auch gar nicht mal so lange nachdem man das erste Modul gemacht hat und weiß, was wo wie gebogen und platziert werden muss….

    Gruß

    Nico

Forumregeln

  • Es ist dir nicht erlaubt, neue Themen zu verfassen.
  • Es ist dir nicht erlaubt, auf Beiträge zu antworten.
  • Es ist dir nicht erlaubt, Anhänge hochzuladen.
  • Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
  •  
Powered by vBadvanced CMPS v4.3.0