DIY-HIFI-Forum

Zurück   DIY-HIFI-Forum > Elektronik > Allgemeine Themen
Registrieren Hilfe Benutzerliste Kalender Alle Foren als gelesen markieren

» Veranstaltungen
 
 
Themen-Optionen
Alt 27.10.2017, 10:19   #21
jhohm
Erfahrener Benutzer
 
Registriert seit: 24.03.2009
Ort: Braunschweig
Beiträge: 1.181
Standard

Zitat:
Zitat von krama1974 Beitrag anzeigen
Das sehe ich anders: ohne DAC ist die Beere nicht Hifi-tauglich. Ob du das hörst hängt sehr von den Komponenten ab, mit denen der "Hifi"-Berry zusammenarbeitet. Wenn du Brüllwürfel vom Discounter verwendest ist auch eine Beere völlig ausreichend, an ersthafter Elektronik rauscht und zischelt er wie mein Wasserkocher.

Weitere Infos? klickmich

Der HifiBerry IST ein DAC...

Gruß Jörn
__________________
Dekadenz ist geil, wenn man Geld hat
guggst Du hier : http://www.joern-hohmann.de
jhohm ist offline   Mit Zitat antworten
Alt 27.10.2017, 11:02   #22
krama1974
Hifi-Zirkel
 
Registriert seit: 15.06.2015
Ort: Oostfreesland
Beiträge: 333
Standard

Hi Joern, man kann jede Bemerkung kommentieren - muss man aber nicht...
__________________
Kundenbindung ist was für Singles.
krama1974 ist offline   Mit Zitat antworten
Alt 27.10.2017, 13:37   #23
bAD kARMA
...ist voll im Stress...
 
Registriert seit: 12.05.2012
Ort: Neuenstadt
Beiträge: 425
Standard

Zitat:
Zitat von icebaer Beitrag anzeigen
Danke für den Vorschlag.
An sich klingt der Hifiberry gut. Allerdings müsste ich dafür ja nicht nur die Netzteile wechseln, sondern auch den Amp. Noch dazu kostet der Hifiberry-Amp leider auch deutlich mehr als der Wondom.

Die Störgeräusche treten auch wirklich nur auf, wenn das Display angeschlossen ist. Ist am Display entweder der Strom- oder der HDMI-Anschluss getrennt, ist alles schön ruhig.

Was ich gefunden habe, ist ein Netzteil, was bereits beide Spannungen am Ausgang liefert: Power Supply Netzteil 12V / 2A und 5V / 2A
Damit muss ich mir keine Gedanken, wegen StepUp/-Down machen, da der vermutlich schon integriert ist. Für die Versorgung des Displays und des Pis sollte das doch ideal sein.
Das Problem ist, dass sich die schlechten Einflüsse vom RPi durch alle Komponenten in die Stromversorgung durchziehen. Deshalb: Der Verstärker braucht eine vom RPi getrennte Stromversorgung sonst kannst du es vergessen. Sonderlösungen mag es geben, aber robust ist diese Vorgehensweise.
__________________
Grüßle Sven
Hört "And I raise my head and stare into the eyes of a stranger" mit seinen DOBs
bAD kARMA ist offline   Mit Zitat antworten
Alt 27.10.2017, 13:48   #24
icebaer
Neuer Benutzer
 
Registriert seit: 11.02.2016
Beiträge: 21
Standard

Zitat:
Zitat von bAD kARMA Beitrag anzeigen
Der Verstärker braucht eine vom RPi getrennte Stromversorgung sonst kannst du es vergessen.
So ist es auch geplant: 2 Netzteile, eins für den Verstärker und eins für Pi + Display
D.h. das neue, duale Netzteil versorgt den Pi mit 5V und das Display mit 12V. Und das bisherige 12V Netzteil bleibt alleine dem Verstärker vorbehalten.
icebaer ist offline   Mit Zitat antworten
Alt 27.10.2017, 18:14   #25
Jackelbarto
Erfahrener Benutzer
 
Registriert seit: 03.03.2015
Beiträge: 159
Standard Dac

Hi,

ich noch mal, mir ist jetzt noch nicht ganz klar ob du einen DAC benutzt oder nicht. Oder hatte ich das überlesen?

Grüße
Rene
Jackelbarto ist offline   Mit Zitat antworten
Alt 27.10.2017, 18:20   #26
icebaer
Neuer Benutzer
 
Registriert seit: 11.02.2016
Beiträge: 21
Standard

Zitat:
Zitat von Jackelbarto Beitrag anzeigen
mir ist jetzt noch nicht ganz klar ob du einen DAC benutzt oder nicht.
In Form einer USB-Soundkarte, ja
icebaer ist offline   Mit Zitat antworten
Alt 28.10.2017, 11:14   #27
JFA
Erfahrener Benutzer
 
Registriert seit: 10.12.2012
Ort: OWL
Beiträge: 1.216
Standard

Zitat:
Zitat von icebaer Beitrag anzeigen
Deswegen sind jetzt zwei Netzteile verbaut:
- 5V (Meanwell RS-15-5)
An dem hängt der Pi

- 12 (Meanwell LRS-100-12)
An dem hängt der Verstärker und das Display

Leider ist meine Befürchtung wegen Störgeräuschen doch eingetroffen. Es kommt ein hochfrequentes Fiepen aus den LS
Sobald ich das Display vom Strom nehme oder das HDMI Kabel zwischen Display und Pi löse, ist das Fiepen weg.
Ein Problem, dem ich häufiger in Foren begegne, ist, dass ich manchmal einfach ignoriert werde. Oder nicht verstanden, aber dann besteht ja die immer noch die Möglichkeit des Nachfragens. Ich habe z. B. in dem Beitrag http://www.diy-hifi-forum.eu/forum/s...2&postcount=13
ein paar allgemein gehaltene Hinweise gegeben.

Die betrafen hauptsächlich die Masseführung, also schauen wir die uns doch einmal in diesem Fall an:
12V -> Display -> HDMI -> Pi -> 5V
Das ist schon einmal suboptimal, denn wenn ich das richtig verstanden habe kommen die 5V und 12V aus dem selben Netzteil, es besteht da also eine Masseverbindung, gleichzeitig hast Du aber auch eine Massverbindung über HDMI, und damit eine geschlossene Schleife.
EMV-Regel Nummer 1): Masseschleifen sind schlecht
Pi und Display werden damit wahrscheinlich trotzdem funktionieren, Dank der digitalen Signalverarbeitung.

Kommt der Verstärker ins Spiel:
5V -> Pi -> USB -> DAC -> Verstärker -> 12V
Da haben wir schon den nächsten Kandidaten als Schleife, und der ist richtig Kacke, denn der Verstärker kann alles mögliche verkraften, aber keine Störungen auf seiner Eingangsseite, denn die werden mit vollem Gain an die Lautsprecher weitergegeben. Hinzu kommt, dass sich dadurch noch eine andere Schleife ergibt:
Pi -> USB -> DAC -> Verstärker -> 12V -> Display -> HDMI -> Pi

Offensichtlich ist diese Schleife für einen Großteil der Störungen verantwortlich, also muss wenigstens diese aufgetrennt werden. Das machst Du am besten genau dort, wo man es sowieso zu machen pflegt, nämlich am DAC.
EMV-Regel Nummer 2) Digital- und Analogmassen müssen getrennt werden
Also: prüfe, ob zwischen Verstärker und Pi eine Masseverbindung besteht, und wenn ja, dann musst Du diese unterbrechen. Das wird mit der USB-Soundkarte nicht so einfach sein, also weg damit. Allein vom Foto her würde ich sagen, das der Hifiberry Dac+ Standard genau diese Trennung hat, also schon eine deutliche Verbesserung darstellt. Mit dieser Maßnahme hast Du schon die beiden Schleifen aufgetrennt, in denen der Verstärker involviert ist.

Weitere mögliche Probleme ergeben sich durch die Spannungsversorgung. Das das Display an den gleichen 12V hängt könnte knifflig sein, allerdings denke ich, dass sowohl Verstärker als auch Display vernünftig abgeblockt sind. Eine andere Sache sind die 5V am DAC. Bei der USB-Soundkarte ist das eine absolute Katastrophe, weil die Spannung so voller Dreck hängt, und nebenbei durch ein haarfeines Drähtchen geführt wird, dass die für anständige Audiowiedergabe einfach nicht geeignet ist. Mit viel Aufwand kann man die wieder sauber bekommen, aber der wird zu selten betrieben. Gut ist, dass Du die USB-Soundkarte sowieso durch was anderes ersetzen willst (s. o.), und du dadurch die Möglichkeit hast, es gleich richtig zu machen. Also: einen DAC mit externer Analog-Spannungsversorgung zu nehmen, also auch nicht die 5V die vom Pi-Board bereit gestellt werden, denn die sind auch Murks.

Eine Verbesserung wäre es, die 5V direkt vom Netzteil zu holen, aber dann hast Du gleich die nächste Schleife über den Verstärker (wenn die niederohmig genug ist, könnte das aber ohne Probleme funktionieren). Richtig wäre: auf bzw. kurz vor dem Verstärker einen Sternpunkt zu schaffen (für Masse UND Spannung), und an diesem die 5V über einen Linearregler aus den 12V zu erzeugen. Der wird so 250mW verbrennen müssen, das ist eigentlich kein Problem für gängige Typen (thermal rating beachten).
JFA ist offline   Mit Zitat antworten
Alt 28.10.2017, 11:31   #28
rkv
Erfahrener Benutzer
 
Registriert seit: 20.11.2015
Ort: Verden
Beiträge: 268
Standard

Zitat:
Zitat von JFA Beitrag anzeigen
Ein Problem, dem ich häufiger in Foren begegne, ist, dass ich manchmal einfach ignoriert werde. Oder nicht verstanden, aber dann besteht ja die immer noch die Möglichkeit des Nachfragens.


Solange das im echten Leben oder in der Firma nicht auch so ist....

rkv ist offline   Mit Zitat antworten
Alt 28.10.2017, 12:28   #29
icebaer
Neuer Benutzer
 
Registriert seit: 11.02.2016
Beiträge: 21
Standard

Zitat:
Zitat von JFA Beitrag anzeigen
Ein Problem, dem ich häufiger in Foren begegne, ist, dass ich manchmal einfach ignoriert werde. Oder nicht verstanden
Ist wohl eine Kombination aus beidem. Nicht ganz verstanden und dadurch *huestel* erstmal ignoriert. War dann eher ein "Augen-zu-und-durch"... mit dem zu erwartendem Erfolg.
Wäre auch zu einfach gewesen, die 12V Verbraucher an ein Netzteil und den 5V Verbraucher an ein anderes Netzteil zu hängen

Auf alle Fälle besten Dank für die ausführliche Erklärung!
Auch wenn mir das mit der Sternförmigen Auftrennung der Masse noch nicht ganz klar ist. Bis zu den Netzteilen geht es dreiadrig mit Wechselstrom und einer extra Masseleitung. Da habe ich ja keine grosse Möglichkeit, was zu ändern, da es in der Steckdose eh wieder zusammen läuft.
Heisst das dann, dass bei den Ausgängen der Netzteile darauf geachtet werden muss, dass die Rückleitungen Netzförmig geschaltet sind?!

Wenn ich es aber sonst richtig verstanden habe, wäre der Ansatz zwei Netzteile zu nehmen, eins für Pi plus Display und eins für den Amp, als die richtige Richtung. Dann wäre ein Teil digital (Pi&Display) und einer analog (Amp).

Die Lösung mit dem Hifiberry-DAC wäre zwar wohl die optimale Lösung. Ist mir momentan aber ehrlich gesagt vom Aufwand zu hoch, weil dann der Grossteil der Hardware getauscht werden müsste.
Ich suche auch keine Hifi-Hi-End-Lösung. Es sollen halt nur keine Störgeräusche vorhanden sein. Das klappt derzeit zumindest, wenn ich das Display an ein eigenes Netzteil hänge und nicht zusammen mit dem Amp an einem gemeinsamen Netzteil betreibe.
icebaer ist offline   Mit Zitat antworten
Alt 28.10.2017, 14:38   #30
JFA
Erfahrener Benutzer
 
Registriert seit: 10.12.2012
Ort: OWL
Beiträge: 1.216
Standard

Ich hatte vorhin Deine Idee mit den zwei getrennten Netzteilen übersehen. Das geht, so einigermaßen zumindest.

Du trennst zwar die Schleifen auf, aber hast trotzdem eine Masseverbindung am DAC. Das ist eigentlich genau die Stelle, wo man so etwas nicht haben will.

Haben die Netzteile einen Schutzleiter?
JFA ist offline   Mit Zitat antworten
Alt 28.10.2017, 15:59   #31
icebaer
Neuer Benutzer
 
Registriert seit: 11.02.2016
Beiträge: 21
Standard

Zitat:
Zitat von JFA Beitrag anzeigen
Haben die Netzteile einen Schutzleiter?
Das Netzteil für den Amp hat einen. Das andere keinen, da gehen nur Phase/Null rein.
icebaer ist offline   Mit Zitat antworten
Alt 28.10.2017, 17:09   #32
JFA
Erfahrener Benutzer
 
Registriert seit: 10.12.2012
Ort: OWL
Beiträge: 1.216
Standard

Dann sollte es eigentlich keine Probleme geben. Könnte sinnvoll sein, am DAC (also direkt am IC) noch die Analogversorgungsspannung ordentlich mit einem C zu puffern. Kommt aber auf die Soundkarte an. Wenn Du keine Störungen hörst ist es nicht nötig
JFA ist offline   Mit Zitat antworten
Alt 03.11.2017, 12:02   #33
icebaer
Neuer Benutzer
 
Registriert seit: 11.02.2016
Beiträge: 21
Standard

Zitat:
Zitat von JFA Beitrag anzeigen
Dann sollte es eigentlich keine Probleme geben.
Eine gute Einschätzung

Nachdem jetzt der Amp ein eigenes Netzteil hat und das Display und der Pi an einem (Dual)Netzteil hängen, ist Schicht im Schacht mit Störgeräuschen

Danke an alle, die geholfen haben!
icebaer ist offline   Mit Zitat antworten
Antwort

Themen-Optionen

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu

Powered by vBadvanced CMPS v3.2.2
Alle Zeitangaben in WEZ +1. Es ist jetzt 06:56 Uhr.


Powered by vBulletin® Version 3.8.9 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.